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Summary
When building the folder structure of your BO System the error occurs.
Error
System.TimeoutException
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The request channel timed out while waiting for a reply after 00:00:59.9990037. Increase the timeout value passed to the call to Request or increase the SendTimeout value on the Binding. The time allotted to this operation may have been a portion of a longer timeout. |
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Message: An HTTP Content-Type header is required for SOAP messaging and none was found. |
Cause
The problem is related to the communication with your BO server and the timeout settings.
Solution 1 (timeout increase)
There is only a workaround we can currently offer by extending your timeout-time.
Note |
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Please create a copy of the "DocuPerformerPerformerSuite.exe.config"-file before editing. |
- Open file DocuPerformerPerformerSuite.exe.config (..\DocuPerformerPerformerSuite\Core\Main)
- Open DocuPerformerPerformerSuite.exe.config in a text editor (e.g. Notepad)
- Jump to line 333433, or search for "system.serviceModel"
- Add a new attribute sendTimeout="00:10:00" to the binding element "DpBoWebServiceClient"
The time format is HH:MM:SS.
The example is 10 minutes.
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<system.serviceModel> <bindings> <basicHttpBinding> <binding name="DpBoWebServiceClient" sendTimeout="00:10:00"> </binding> </basicHttpBinding> </bindings> </system.serviceModel> |
Solution 2 (stabilize folder retrieval)
If the "timeout-value-increase" still does not work, you can switch to the slower, but more stable way of calling the folder structure:
- Go to the folder ..\DocuPerformerPerformerSuite\Core\Main
- Find the file DocuPerformerPerformerSuite.exe.config
- Open this file DocuPerformerPerformerSuite.exe.config with a text editor
- Jump to line 236319, RetrieveFoldersUseRestful and change the value from false to true
- Save the file
- Restart the Docu Performer Suite
- Try again the sync or documentation
Solution 3 (hide favorites folder)
In some cases loading the folder structure fails, then we need a "false".
- "false" does not show hides the "Favorite folders" in the BO folder tree
- "true" shows the "Favorite folders" in the BO folder tree
- Go to the folder ..\DocuPerformerPerformerSuite\Core\Main
- Find the file DocuPerformerPerformerSuite.exe.config
- Open this file DocuPerformerPerformerSuite.exe.config with a text editor
- Jump to line 233316, RetrieveFavoritesFolder and change the value from true to false
- Save the file
- Restart the Docu Performerthe Performer Suite
- Try again the sync