Table of Contents
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Summary
The initial Oracle database connection fails.
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.
Cause
Missing authorization.
Solution
Start the PerformerSuite.exe as Administrator.
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Error (could not resolve the connect identifier specified)
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ORA-12154: TNS: could not resolve the connect identifier specified
ORA-12154: TNS: Angegebener Connect Identifier konnte nicht aufgelöst werden |
Cause
The Performer Suite cannot translate your entered Oracle hostname into an IP.
Normally the file TNSNAMES.ORA is responsible for this translation (path: $ORACLE_HOME/network/admin), but unfortunately, Performer Suite cannot use this file.
Solution
- Try to enter the real IP as "server name", e.g. 12.345.678.910:1521
- If it still does not connect 12.345.678.910:1521/<ServiceName>
- Or even the complete connection string. (DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=<host>) (PORT=<port>))(CONNECT_DATA=(SERVICE_NAME=<serviceName>))
Described in more detail here: ORACLE: Configure connection
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Error (connection could not be established)
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Error, the connection could not be established. |
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DocuPerformer.log (C:\Users\<USER>\Documents\BI Docu Performer\Log)
writes the following line:
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'System.InvalidOperationException: Attempt to load Oracle client libraries threw BadImageFormatException.
This problem will occur when running in 64 bit mode with the 32 bit Oracle client components installed. |
Cause
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Your Docu Performer Your Performer Suite BIT-version is incompatible with your Oracle Client.
Solution
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Install the same BIT-version for the Docu Performer the Performer Suite and the Oracle Client.
i.e. 64-bit Docu Performer ↔ Performer Suite ↔ 64-bit Oracle Client
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Error
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(requires Oracle client software version 8.1.7 or greater)
PerformerSuite.log (C:\Users\<USER>\Documents\BI Docu Performer Suite\Log)
writes the following line:
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'System.Exception: System.Data.OracleClient requires Oracle client software version 8.1.7 or greater. |
Cause
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Oracle Client folder missing permissions.
Solution
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- Go to the Oracle Client folder.
- Right-click on the folder → Properties → Security
- Add “Authenticated Users” and give this account Read & Execute permission.
- Apply this security for all folders, subfolders, and files (IMPORTANT).
- REBOOT your machine (if you don't do this you will still face the same problem)
Solution 2
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- Set your environment variable to the Oracle Client path