Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.


Table of Contents

...

Summary

The initial Oracle database connection fails.

...

.

Cause

Missing authorization.

Solution

Start the PerformerSuite.exe as Administrator.

...

Error (could not resolve the connect identifier specified)

Code Block
languagecpp
themeDJango
ORA-12154: TNS: could not resolve the connect identifier specified
ORA-12154: TNS: Angegebener Connect Identifier konnte nicht aufgelöst werden

Cause

The Performer Suite cannot translate your entered Oracle hostname into an IP.
Normally the file TNSNAMES.ORA is responsible for this translation (path: $ORACLE_HOME/network/admin), but unfortunately, Performer Suite cannot use this file.

Solution

  1. Try to enter the real IP as "server name", e.g. 12.345.678.910:1521
  2. If it still does not connect 12.345.678.910:1521/<ServiceName>
  3. Or even the complete connection string. (DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=<host>) (PORT=<port>))(CONNECT_DATA=(SERVICE_NAME=<serviceName>))
    Described in more detail here: ORACLE: Configure connection

...

Error (connection could not be established)

Code Block
languagecpp
themeDJango
Error, the connection could not be established.


Code Block

Image Removed

DocuPerformer.log (C:\Users\<USER>\Documents\BI Docu Performer\Log)
writes the following line:

...

languagecpp
themeDJango
'System.InvalidOperationException: Attempt to load Oracle client libraries threw BadImageFormatException.
This problem will occur when running in 64 bit mode with the 32 bit Oracle client components installed.

Cause

...

Your Docu Performer Your Performer Suite BIT-version is incompatible with your Oracle Client.

Solution

...

Install the same BIT-version for the Docu Performer the Performer Suite and the Oracle Client.
i.e. 64-bit Docu Performer ↔  Performer Suite ↔ 64-bit Oracle Client

...


Error

...

(requires Oracle client software version 8.1.7 or greater)

PerformerSuite.log (C:\Users\<USER>\Documents\BI Docu Performer Suite\Log)
writes the following line:

Code Block
languagecpp
themeDJango
'System.Exception: System.Data.OracleClient requires Oracle client software version 8.1.7 or greater.

Cause

...

Oracle Client folder missing permissions.

Solution

...

  1. Go to the Oracle Client folder.
  2. Right-click on the folder → Properties → Security
  3. Add “Authenticated Users” and give this account Read & Execute permission.
  4. Apply this security for all folders, subfolders, and files (IMPORTANT).
  5. REBOOT your machine (if you don't do this you will still face the same problem)

Solution 2

...

  • Set your environment variable to the Oracle Client path

Image Modified