Summary
When building the folder structure of your BO System the error occurs.
Error
System.TimeoutException
The request channel timed out while waiting for a reply after 00:00:59.9990037. Increase the timeout value passed to the call to Request or increase the SendTimeout value on the Binding. The time allotted to this operation may have been a portion of a longer timeout.
Message: An HTTP Content-Type header is required for SOAP messaging and none was found.
Cause
The problem is related to the communication with your BO server and the timeout settings.
Solution 1
There is only a workaround we can currently offer by extending your timeout-time.
Please create a copy of the "DocuPerformer.exe.config"-file before editing.
- Open file DocuPerformer.exe.config (..\DocuPerformer\Core\Main)
- Open DocuPerformer.exe.config in a text editor (e.g. Notepad)
- Jump to line 333, or search for "system.serviceModel"
- Add a new attribute sendTimeout="00:10:00" to the binding element "DpBoWebServiceClient"
The time format is HH:MM:SS.
The example is 10 minutes.
<system.serviceModel> <bindings> <basicHttpBinding> <binding name="DpBoWebServiceClient" sendTimeout="00:10:00"> </binding> </basicHttpBinding> </bindings> </system.serviceModel>
Solution 2
If the "timeout-value-increase" still does not work, you can switch to the slower, but more stable way of calling the folder structure:
- Go to the folder ..\DocuPerformer\Core\Main
- Find the file DocuPerformer.exe.config
- Open this file DocuPerformer.exe.config with a text editor
- Jump to line 236, RetrieveFoldersUseRestful and change the value from false to true
- Save the file
- Restart the Docu Performer
- Try again the sync or documentation