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Summary

When building the folder structure of your BO System the error occurs.

Error

System.TimeoutException

The request channel timed out while waiting for a reply after 00:00:59.9990037.
Increase the timeout value passed to the call to Request or increase the SendTimeout value on the Binding.
The time allotted to this operation may have been a portion of a longer timeout.
Message:
An HTTP Content-Type header is required for SOAP messaging and none was found.

Cause

The problem is related to the communication with your BO server and the timeout settings. 

Solution 1 (timeout increase)

There is only a workaround we can currently offer by extending your timeout-time.

Please create a copy of the "PerformerSuite.exe.config"-file before editing.

  1. Open file PerformerSuite.exe.config (..\PerformerSuite\Core)
  2. Open PerformerSuite.exe.config in a text editor (e.g. Notepad)
  3. Jump to line 333, or search for "system.serviceModel"
  4. Add a new attribute sendTimeout="00:10:00" to the binding element "DpBoWebServiceClient"


    The time format is HH:MM:SS.
    The example is 10 minutes.
  <system.serviceModel>
    <bindings>
      <basicHttpBinding>
        <binding name="DpBoWebServiceClient" sendTimeout="00:10:00">
        </binding>
      </basicHttpBinding>
    </bindings>
  </system.serviceModel>

Solution 2 (stabilize folder retrieval)

If the "timeout-value-increase" still does not work, you can switch to the slower, but more stable way of calling the folder structure:

  1. Go to the folder ..\PerformerSuite\Core
  2. Find the file PerformerSuite.exe.config
  3. Open this file PerformerSuite.exe.config with a text editor
  4. Jump to line 236, RetrieveFoldersUseRestful and change the value from false to true
  5. Save the file
  6. Restart the Performer Suite
  7. Try again the sync or documentation

Solution 3 (hide favorites folder)

In some cases loading the folder structure fails, then we need a "false".

  • "false" does not show the "Favorite folders" in the BO folder tree
  • "true" shows the "Favorite folders" in the BO folder tree
  1. Go to the folder ..\PerformerSuite\Core
  2. Find the file PerformerSuite.exe.config
  3. Open this file PerformerSuite.exe.config with a text editor
  4. Jump to line 233, RetrieveFavoritesFolder and change the value from true to false
  5. Save the file
  6. Restart the Performer Suite
  7. Try again the sync

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