Document toolboxDocument toolbox

OneDrive backup of \Documents-folder causing a lock


Summary

An DB Update can fail or an SAP Synchronization can fail if OneDrive is set by your company policy to constantly backup your Documents-User folder.

Error

EN: The process cannot access the file 'C:\Users\<USER>\Documents\PerformerSuite\Log\PerformerSuite.log' because it is being used by another process.
DE: Der Prozess kann nicht auf die Datei xxxx zugreifen, da sie von einem anderen Prozess verwendet wird.
EN: The tag present in the reparse point buffer is invalid.
DE: Das im Analysepunktpuffer vorhandene Kennzeichen ist ungültig.

Cause

OneDrive is locking the PerformerSuite.log file by constantly backing up the file.

Solution

1) Command Line Argument

Move the folder away, with the help of a Command-Line Argument, from your Documents-User folder to a directory that is not covered by the OneDrive backup process.
How-To:

Add to your PerformerSuite.exe shortcut the following extension.

PerformerSuite.exe -u C:\Temp\PerformerSuiteUserPath

It should look like this:

If you now start the PerformerSuite shortcut the file PerformerSuite.log is now created inside the new directory C:\Temp\PerformerSuite\Log.

2) Set an Exception

Find a way to set an exception to prevent OneDrive from constantly backing up the PerformerSuite.log.
https://support.microsoft.com/en-us/office/choose-which-onedrive-folders-to-sync-to-your-computer-98b8b011-8b94-419b-aa95-a14ff2415e85



Feel free to create a ticket in our Help Desk and attach the PerformerSuite.log-file, if you need any support.
Thank you!

PerformerSuite.log (C:\Users\<USER>\Documents\PerformerSuite\Log)


© 2024 bluetelligence GmbH. All rights reserved.
No part of this publication may be reproduced or transmitted in any form or for any purpose without the express permission of bluetelligence GmbH. The information contained herein may be changed without prior notice. bluetelligence and Performer Suite and their respective logos are trademarks or registered trademarks of bluetelligence GmbH. SAP, ABAP, BAPI, SAP NetWeaver, SAP BI, SAP BW, SAC, and other SAP products and services mentioned herein as well as their respective logos are trademarks or registered trademarks of SAP AG in Germany or an SAP affiliate company. All other product and service names mentioned are the trademarks of their respective companies.
Impressum – Legal Notice: https://bluetelligence.de/en/imprint
Privacy policy: https://performersuite.de/en/privacy-policy
Atlassian privacy policy: https://www.atlassian.com/legal/privacy-policy